Java Tutorial

How To Fix Java Unsupported major.minor Version 51.0 Exception

When you run a program in Eclipse or command line. You may encounter the following exception java.lang.UnsupportedClassVersionError: Unsupported major.minor version 51.0. This is because your java class compiler version is bigger than the java class runtime version. In my environment, my java runtime version is 1.6, but my eclipse java compiler version is 1.8. So

How To Fix Java Unsupported major.minor Version 51.0 Exception Read More »